php.ini

Fixed and closed topics
Anthony

php.ini

Post by Anthony »

where is that file located?
it tells me i have to "# Enable php_pdf.dll in the php.ini"

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Post by wbartels »

In your windows directory.
Normally: C:\WINNT\php.ini or C:\WINDOWS\php.ini

Mephistois

Post by Mephistois »

edit your php.ini.

you will find:

Code: Select all

;extension=php_pdf.dll
just edit it to

Code: Select all

extension=php_pdf.dll
and restart your webserver. :wink:

Guest

Post by Guest »

I am also having the same problem...I enabled php_pdf.dll in the php.ini file and restarted the server. But I'm still receiving the same error message on the index page after doing so.

I changed:

;extension=php_pdf.dll

to

extension=php_pdf.dll....restarted server. Cleared my cache.

Still getting the error message:

PDF extension not loaded

Enable php_pdf.dll in the php.ini

Restart webserver

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Post by wbartels »

Anonymous wrote:I am also having the same problem...I enabled php_pdf.dll in the php.ini file and restarted the server. But I'm still receiving the same error message on the index page after doing so.

I changed:

;extension=php_pdf.dll

to

extension=php_pdf.dll....restarted server. Cleared my cache.

Still getting the error message:

PDF extension not loaded

Enable php_pdf.dll in the php.ini

Restart webserver
Have you installed PHP with the installer package?
This package doesn't include the required external extensions :(
Use the zip package instead :wink:

Guest

Post by Guest »

hallo

ich habe linux server und im php.ini gibts gar nicht ;extension=php_pdf.dll

was soll ich machen ?

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Post by wbartels »

Anonymous wrote:hallo

ich habe linux server und im php.ini gibts gar nicht ;extension=php_pdf.dll

was soll ich machen ?
The ;extension=php_pdf.dll is only for Windows
You have to compile php with PDF support.
I can't help you with that, because my Linux knowledge is very limited.

newbeat

The ;extension=php_pdf.dll is only for Windows

Post by newbeat »

extension=php_pdf.dll is only for Windows

extension=libpdf_php.so is only for Linux ,BSD.
But , u must recompile ur PHP again ..... check this link out ( i disabled pdf support in NJB).
http://pdflib.com/support/faq/readme_php.txt

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Re: The ;extension=php_pdf.dll is only for Windows

Post by wbartels »

So this would be a better error message for none Windows:

PDF not supported
Compile PHP with PDF support
or use a loadable module (libpdf_php.so)
For more information: http://www.pdflib.com/


I assume the same counts for GD2 and MySQL.
What are the most common names for these loadable modules?
Is there a GD2 website?
<edit> I found the gd website: http://www.boutell.com/gd/ </edit>

Thanks,

Willem

PS
In the next netjukebox version I only check for PDF support in the cover.php function.

newbeat

php.ini

Post by newbeat »

gd2 works fine on xampp

but i have other troubles with NJB on xampp.
I edited iconv and pdflib in include/initialize.inc.php (last ur tricks in General discussion for iconv and pdf); now started NJB,but i get new errors messages.

Warning: Cannot modify header information - headers already sent by (output started at /www/netjukebox/include/initialize.inc.php:306) in /www/netjukebox/include/initialize.inc.php on line 125
= header('Cache-Control: no-store, no-cache, must-revalidate'); // HTTP/1.1

Warning: Cannot modify header information - headers already sent by (output started at /www/netjukebox/include/initialize.inc.php:306) in /www/netjukebox/include/initialize.inc.php on line 126
=header('Pragma: no-cache');// HTTP/1.0

Warning: Cannot modify header information - headers already sent by (output started at /www/netjukebox/include/initialize.inc.php:306) in /www/netjukebox/include/initialize.inc.php on line 179
=setcookie('netjukebox_username', $username, $expire, '');

Warning: Cannot modify header information - headers already sent by (output started at /www/netjukebox/include/initialize.inc.php:306) in /www/netjukebox/include/initialize.inc.php on line 180
=setcookie('netjukebox_expire', $expire, $expire, '');

Warning: Cannot modify header information - headers already sent by (output started at /www/netjukebox/include/initialize.inc.php:306) in /www/netjukebox/include/initialize.inc.php on line 181
=setcookie('netjukebox_hash', $hash, $expire, '');

When i try to click for some button (browse,favourites,user,config or other), i get everytime only startsite with login dialog).
It seems, that all works fine, but initialize.inc.php is wrong configured.

Maybe u need to have much knowledges about Linux or Bsd Willem, u can simple fix these errors in ur NJB .config.
If u have a bit time, myabe u can try xampp with some LiveCD (linux,bsd) distro for checking php troubles on Linux.

newbeat

php.ini

Post by newbeat »

edit : Maybe u need to have much knowledges about Linux or Bsd Willem =
Maybe u dont need to have much knowledges about Linux or Bsd Willem..

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Re: php.ini

Post by wbartels »

newbeat wrote:edit : Maybe u need to have much knowledges about Linux or Bsd Willem =
Maybe u dont need to have much knowledges about Linux or Bsd Willem..
I'm now working hard on netjukebox 3.76 with a new login system.
If this is functional ready I will try netjukebox on a Linux distribution.

Is Fedora a good distribution for a Linux beginner?
Or should I looking for another distribution?

Willem

newbeat

php.ini

Post by newbeat »

Is Fedora a good distribution for a Linux beginner?
Or should I looking for another distribution?


Its sure good newbie's distro, but it isnt good linux (clean) distro, like mandrake,suse and 20 other distros.
I think, that only 3 - 4 distros are interesting for develops to use.
Slackware,debian,gentoo and archlinux are very clean,stable,modern and fast.
U can try Ubuntu (debian based),Zenwalk with RT kernel ;) (slackware based),Vidalinux (gentoo based, but a bit bugy) or ..... PC-BSD (easy installer,BSD + linux at once :P).

User avatar
wbartels
netjukebox developer
Posts: 823
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Re: php.ini

Post by wbartels »

newbeat wrote:Is Fedora a good distribution for a Linux beginner?
Or should I looking for another distribution?


Its sure good newbie's distro, but it isnt good linux (clean) distro, like mandrake,suse and 20 other distros.
I think, that only 3 - 4 distros are interesting for develops to use.
Slackware,debian,gentoo and archlinux are very clean,stable,modern and fast.
U can try Ubuntu (debian based),Zenwalk with RT kernel ;) (slackware based),Vidalinux (gentoo based, but a bit bugy) or ..... PC-BSD (easy installer,BSD + linux at once :P).
I have installed Fedora on VMWare.
But the standard PHP and MySQL versions where to high.

Witch Linux distribution have these pachages?
Apache 2.0.54 or 1.3.33
PHP 4.4.0
MySQL 4.0.x

newbeat

php.ini

Post by newbeat »

Dear Willem,
I dont know, which distro has such versions, but i think, u can get all versions, what u need for all linux distros (like package, or u can self compile own version - typical for php)
But i think, that u can make ur Linux adventures much easily, if u look for xampp.
Xampp is full executable progie without touching of registry or hardisc (like live CD).Look here for xampp http://www.apachefriends.org/de/xampp-linux.html , and if u need old versions of php,apache or mysql, take old xampp version.
U need only download xampp for linux, tar xvfz xampp-linux-1.4.16.tar.gz -C /opt, edit in apache folder httpd.conf for new rootdocument = netjukebox, and /opt/lampp/lampp start.
I must tell, that i have big troubles with php,mysql,sqlite3,lighttpd on my harddic, but i have never troubles with xampp.

Locked