Stream cuts out at 5 minutes into a song

This is not a bug or can't reproduce
Locked
ix6tech
User
Posts: 49
Joined: Thu Jun 01, 2006 6:09 pm
Location: Dallas, TX
Contact:

Stream cuts out at 5 minutes into a song

Post by ix6tech » Thu Jan 22, 2015 9:08 pm

When streaming music using the source streaming profile at approx. 5 minutes 30 minutes to 5 minutes 49 seconds at random intervals with different songs when streaming an album. This has been observed to happen on both a local test platform, and remote platform.

Platform: CentOS 6
Player used to stream: VLC Player 2.1.5 Rincewind
Stream Profile: Source

Note: This does not occur if you manually fast-forward to the 5 minute 30 second mark into a track. (Testing this will require some patience)

Steps to reproduce:

1) Select an album that has tracks lasting 6 minutes or longer.
2) Select “Stream Album”.
3) Listen to the tracks, and maintain time with each track from start to finish.

Expected Results:

Continuous play of each track should playout from start to finish.

Actual Results:

Continuous play will skip after 5 minutes and 30 seconds of play on a track, and flip to the next track in the playlist.

User avatar
wbartels
netjukebox developer
Posts: 798
Joined: Thu Nov 04, 2004 3:12 pm
Location: Netherlands
Contact:

Re: Stream cuts out at 5 minutes into a song

Post by wbartels » Fri Jan 23, 2015 9:14 pm

I can't reproduce this problem.
Source, transcode and realtime transcode set the expire time to endless with:

Code: Select all

ini_set('max_execution_time', 0);
Most hosting providers don't allow to change the max_execution_time value with the ini_set() function.
It is possible to check if the value is set correctly with:

Code: Select all

<?php 
echo ini_set('max_execution_time', 0) ? 'max_execution_time set' : 'max_execution_time error';
 ?>

Locked